设为首页 双色球直播

双色球app官网下载: 双色球直播

查看: 528|回复: 0
打印 上一主题 下一主题

[经验分享] 误删Cisco IOS文件恢复

[复制链接]

尚未签到

跳转到指定楼层
1#
发表于 2018-7-17 14:01:49 | 只看该作者 回帖奖励 |倒序浏览 |阅读模式
  rommon #1> ?
  Variables: Use "sync" to store in NVRAM
  ADDRESS= local IP address
  CONFIG= config file path/name
  GATEWAY= gateway IP address
  IMAGE= image file path/name
  LINKTIMEOUT= Link UP timeout (seconds)
  PKTTIMEOUT= packet timeout (seconds)
  PORT= ethernet interface port
  RETRY= Packet Retry Count (Ping/TFTP)
  SERVER= server IP address
  VLAN= enable/disable DOT1Q tagging on the selected port
  rommon #2> ADDRESS=192.168.0.2 (因为是TFFP上传,所以防火墙设置为客户机)
  rommon #3> GATEWAY=192.168.0.1 (网关)
  rommon #4> IMAGE=asa802-k8.bin (导入IOS的名称)
  rommon #5> SERVER=192.168.0.1 (服务器IP,也就是你的PC)
  rommon #6> sync (保存)
  Updating NVRAM Parameters...
  rommon #7> ping 192.168.0.1
  Sending 20, 100-byte ICMP Echoes to 192.168.0.1, timeout is 4 seconds:
  ?!!!!!!!!!!!!!!!!!!!
  Success rate is 95 percent (19/20)
  确认线路是否连通,开启TFTP软件 (这里说明下我测试是ASA5505 所以接的E0/0口。不知道设备该接什么口可以用set看“PORT=Ethernet0/0”)
  rommon #8> tftpdnld (上传)
  ROMMON Variable Settings:
  ADDRESS=192.168.0.2
  SERVER=192.168.0.1
  GATEWAY=192.168.0.1
  PORT=Ethernet0/0
  VLAN=untagged
  IMAGE=asa802-k8.bin
  CONFIG=
  LINKTIMEOUT=20
  PKTTIMEOUT=4
  RETRY=20
  tftp [email protected] via 192.168.0.1
  !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
  导入后设备重启,现在有了IOS 能进去
  Type help or '?' for a list of available commands.
  ciscoasa> en
  但现在IOS也没有装入设备,而是从tftp引导启动设备,断开TFTP服务器就会从新进入监控模式。这一点当设备启动完毕后可以用show version命令看到:
  System image file is "tftp://192.168.0.1/asa802-k8.bin"
  现在需要把IOS存入设备,但是现在防火墙和PC已经不能通信
  ciscoasa# ping 192.168.0.1
  Type escape sequence to abort.
  Sending 5, 100-byte ICMP Echos to 192.168.0.1, timeout is 2 seconds:
  No route to host 192.168.0.1
  Success rate is 0 percent (0/1)
  因为刚才是在监控模式下,现在需要配置让PC和防火墙从新通信(具体型号具体设置,下面已我手上的5505为例)
  interface Vlan1
  nameif inside
  security-level 100
  ip address 192.168.1.1 255.255.255.0
  !
  interface Vlan2
  nameif outside
  security-level 0
  ip address 192.168.0.2 255.255.255.0
  !
  interface Ethernet0/0
  switchport access vlan 2
  现在测试
  ciscoasa# ping 192.168.1.1
  Type escape sequence to abort.
  Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
  !!!!!
  Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
  已经能通信,下面拷贝IOS和ASDM存入设备
  ciscoasa# copy tftp://192.168.0.1/asa802-k8.bin disk0:/asa802-k8.bin
  Address or name of remote host ?
  Source filename ?
  Destination filename ?
  Accessing tftp://192.168.0.1/asa802-k8.bin. ... !!!!!!!!!!!!!!!!!!!
  因为删除的是flash 现在还需要导入ASDM (注意ASDM和IOS的兼容,不兼容如下图)
  进行ciscoasa# copy tftp://192.168.0.1/asa802-k8.bin disk0:/asa802-k8.bin一直报错。
  ciscoasa# show flash:
  Initializing disk0: cache, please wait...Failed (Invalid DOS media or no media in slot error).
  %Error show flash: (Failed to initialize the Inode table)
  ciscoasa# dir disk0:
  %Error opening disk0:/ (Invalid DOS media or no media in slot)
  ciscoasa# fsck flash:
  Initializing disk0: cache, please wait...Failed (Invalid DOS media or no media in slot error).
  Internal error, inode table initialization for flash: failed with error Invalid DOS media or no media in slot
  %Error checking flash: (Invalid DOS media or no media in slot)
  WARNING: Restoring security context mode failed.
  最后使用ciscoasa# format flash: 命令后正常。
  ciscoasa# copy tftp://192.168.0.1/asdm-602.bin disk0://asdm-602.bin
  Address or name of remote host ?
  Source filename ?
  Destination filename ?
  Accessing tftp://192.168.0.1/asdm-602.bin.. ... !!!!!!!!!!!!!!!!!!!
  现在可以看见IOS以后在设备上
  ciscoasa# show version
  Cisco Adaptive Security Appliance Software Version 8.2(1)
  Compiled on Tue 05-May-09 22:45 by builders
  System image file is "disk0:/asa821-k8.bin"
  Config file at boot was "startup-config"
  ciscoasa# show flash:
  --#-- --length-- -----date/time------ path
  3 4096 Aug 26 2009 17:41:50 log
  10 4096 Aug 26 2009 17:41:56 crypto_archive
  11 4096 Aug 26 2009 17:59:06 coredumpinfo
  12 43 Aug 27 2009 09:13:02 coredumpinfo/coredump.cfg
  78 16275456 Aug 26 2009 18:07:50 asa802-k8.bin
  80 7598456 Aug 27 2009 09:05:54 asdm-602.bin
  设置启动文件
  ciscoasa (config)# boot system disk0:/asa802-k8.bin 设置IOS
  ciscoasa (config)# asdm image disk0:/asdm602.bin 设置ASDM

  ciscoasa (config)#>
+1 0

运维网声明 1、欢迎大家加入本站运维交流群:群①:263444886群②:197202523群③:485755530群④:201730672群⑤:202807635运维网交流群⑥:281548029
2、本站所有主题由该帖子作者发表,该帖子作者与双色球直播享有帖子相关版权
3、所有作品的著作权均归原作者享有,请您和我们一样尊重他人的著作权等合法权益。如果您对作品感到满意,请购买正版
4、禁止制作、复制、发布和传播具有反动、淫秽、色情、暴力、凶杀等内容的信息,一经发现立即删除。若您因此触犯法律,一切后果自负,我们对此不承担任何责任
5、所有资源均系网友上传或者通过网络收集,我们仅提供一个展示、介绍、观摩学习的平台,我们不对其内容的准确性、可靠性、正当性、安全性、合法性等负责,亦不承担任何法律责任
6、所有作品仅供您个人学习、研究或欣赏,不得用于商业或者其他用途,否则,一切后果均由您自己承担,我们对此不承担任何法律责任
7、如涉及侵犯版权等问题,请您及时通知我们,我们将立即采取措施予以解决
8、联系人Email:[email protected] 网址:双色球直播 www.dh5vg.com.cn

点击关注更多内容
您需要登录后才可以回帖 登录 | 立即注册  

本版积分规则  允许回帖邮件提醒楼主

扫码加入运维网微信交流群X

扫码加入运维网微信交流群

扫描二维码加入运维网微信交流群,最新一手资源尽在官方微信交流群!快快加入我们吧...

扫描微信二维码查看详情

客服 E-mail:[email protected]

本站由青云提供云计算服务

运维网--中国最专业的运维工程师交流社区

京ICP备14039699号-1 Copyright ? 2012-2020

使用手机软件扫描微信二维码

关注我们可获取更多热点资讯

Good good study day day up !


提醒:禁止发布任何违反国家法律、法规的言论与图片等内容;本站内容均来自个人观点与网络等信息,非本站认同之观点.


本站大部分资源是网友从网上搜集分享而来,其版权均归原作者及其网站所有,我们尊重他人的合法权益,如有内容侵犯您的合法权益,请及时与我们联系进行核实删除!


独家合作伙伴: 青云cloud

快速回复 双色球直播 返回列表
  • 少些功利才能重拾学习的乐趣 2019-04-23
  • 六大工程培育发展新动能 2019-04-23
  • 纯人力飞机面世:跑两步就上天,网友:怎么降落? 2019-04-23
  • 对话内地宫颈癌九价疫苗首批接种者:26岁姑娘最着急 2019-04-22
  • 《龙虾刑警》打响暑期档喜剧“头炮” 沈腾低调现身 2019-04-22
  • 法国“1欧元一套房”竟然乏人问津,这是为什么? 2019-04-22
  • 贯彻五大理念  落实五大统筹 2019-04-21
  • 陕西首家省级主流茶媒体 2019-04-21
  • 好爸爸开讲:这是我的童年 我的大指挥官 2019-04-21
  • 光是一个梨子的滋味就改变了方向,说讲事实摆道理,就是要你按他的指挥棒转,属于忽悠网友的口实 2019-04-21
  • 【城市学】城市学是如何产生的?它经历了怎样的发展历程? 2019-04-20
  • 为乡村振兴贡献党校智慧和力量 2019-04-20
  • 的确,呆子七窍通了栁窍。[哈哈] 2019-04-20
  • 打好企业降成本政策组合拳   2019-04-20
  • 杭宁高速改扩建加大通行压力 2019-04-19
  • 344| 783| 965| 642| 232| 527| 983| 198| 194| 964|